InstallationGetting Started

Expand all | Collapse all

Activating a new delegate host

  • 1.  Activating a new delegate host

    Posted 02-10-2017 09:57 AM

    I am trying to setting a resource (delegate) host with Zenoss 5. My master host has been setup for almost a year (upgraded to CC 1.2.1-1; Zenoss 5.2.1). I just built a delegate host using the instructions on Zenoss.com (CC 1.2.2-1), including setting up all the SERVICED variables. I can add the delegate host into CC on my master host and the delegate is able to authenticate, but it's not listed as "active".

    When I go to move a service over to the delegate host it doesn't work. The health check keeps failing. When viewing journalctl on the delegate there are no logs indicating a problem or the service even attempting to move to the delegate.

    Any thoughts on what might be the cause



  • 2.  I rebuilt my delegate host

    Posted 02-13-2017 03:18 PM

    I rebuilt my delegate host and tried adding it into control center and I still ran into the same problem.

    I rebuilt my master host and added the delegate host to the fresh install and ran into the same problem.

    The only log message I see that might pertain to this would be this sequence:

    serviced[11336]: time="2017-02-13T22:09:27Z" level=info msg="Received new authentication token" expiration=1487027367 location="token.go:55" logger=auth
    serviced[11336]: time="2017-02-13T22:09:32Z" level=info msg="Determined pool assignment for this delegate" hostid=853e7002 location="daemon.go:814" logger=cli.api master=":4979" poolid=default
    serviced[11336]: time="2017-02-13T22:09:38Z" level=info msg="Updated master with delegate host information" hostid=853e7002 location="daemon.go:826" logger=cli.api master=":4979" poolid=default
    serviced[11336]: W0213 22:10:27.935340 11336 connection.go:257] timed out waiting for connection

    I'm also upload a picture of what I'm seeing in Control Center.



  • 3.  Both system are on the same

    Posted 02-14-2017 07:53 AM

    Both system are on the same subnet. That being said, here's a port scan:

    PORT STATE SERVICE
    22/tcp open ssh
    53/tcp open domain
    80/tcp open http
    111/tcp open rpcbind
    443/tcp open https
    2049/tcp open nfs
    2181/tcp open unknown
    4242/tcp open vrml-multi-use
    4979/tcp open unknown
    5000/tcp open upnp
    5042/tcp open unknown
    5043/tcp open unknown
    8443/tcp open https-alt
    20048/tcp open unknown
    22250/tcp open unknown
    42710/tcp open unknown
    50000/tcp open ibm-db2
    53651/tcp open unknown



  • 4.  These are built as VMs. I

    Posted 02-16-2017 07:19 AM

    These are built as VMs. I built another delegate host on the same virtual hostas the master host, connected to the same vSwitch, and I still have the same problem.



  • 5.  I figured it out on my own.

    Posted 02-16-2017 01:24 PM

    I figured it out on my own.

    The documentation is missing a couple of variables that should be setup, even in a two host setup:

    SERVICED_MASTER_IP

    SERVICED_ZK

    I had setup the SERVICED_MASTER_IP out of common sense. I had to also setSERVICED_ZK for the host to become active. This isn't stated in the documentation.



  • 6.  Trial and error based on

    Posted 03-10-2017 01:34 PM

    Trial and error based on educated guesses.

    I worked my way to the conclusion that the issue was with serviced since the host was authenticating and ports were definitely open. I just started going through serviced variables I thought might contribute to the issue, usually skipping over the ZK variables because I'm not using ZK.

    Obivously I ended up changing that variable. The default value lists "SERVICED_MASTER_IP" so I gave it a shot.



  • 7.  RE: Trial and error based on

    Posted 10-30-2017 05:42 AM
    Thanks I have exactly the same issue, not much besides this one forum post on the entire web to answer my query.

    Anyway ill give it a go now, has this been fed back to Zenoss at all? I have noticed a few issues in various documentations over the last 6 months and they are quite receptive when you let them know something is wrong or missing.

    ------------------------------
    FirstName LastName
    CompanyName
    ------------------------------



  • 8.  RE: Trial and error based on

    Posted 10-30-2017 05:51 AM
    Hi, yes this worked fine thanks very much.

    ------------------------------
    Matt B
    ------------------------------