Configuration & Administration

Expand all | Collapse all

Zenoss 6.3.2 - Unable to load the visualization library

  • 1.  Zenoss 6.3.2 - Unable to load the visualization library

    Posted 07-08-2020 03:41 AM
    Hi everyone,

    I'm running Zenoss 6.3.2 without issues since a while but a couple of days ago I ran into the issue that I'm not getting any graphs anymore, instead of the graphs I' getting the error message "Unable to load the visualization library."

    The components (harddisks, network adapters, ...) do not show any actual values from collection, only values from discovery (which works fine) are shown.

    Interestingly collection seems to work as events are created properly.

    Any help or advice would be highly appreciated

    Many thanks in advance,
    Gerald

    ------------------------------
    Gerald Müller
    ------------------------------


  • 2.  RE: Zenoss 6.3.2 - Unable to load the visualization library

    Posted 07-08-2020 04:17 AM
    Found the issue, CentralQuery was not running properly as it ran into a memory issue as described in https://community.zenoss.com/forum/community-home/digestviewer/viewthread?MessageKey=6d630551-8c3f-4442-a2c0-69c636782dae&CommunityKey=1518fed6-b03e-410b-81b9-f2240ed9037a&tab=digestviewer

    Does anyone know if setting the parameter environment=JVM_ARGS="-Xmx4096m" is the proper approach?

    Thanks

    ------------------------------
    Gerald Müller
    ------------------------------



  • 3.  RE: Zenoss 6.3.2 - Unable to load the visualization library

    Posted 07-08-2020 09:52 PM
    Hi, Gerald!

    If you look at the args in the older post you linked, you'll see that the RAM commitment for the service is called as a variable (JVM_ARGS="-Xmx{{bytesToMB .RAMCommitment}}m").  Rather than plug in a value, you can simply click "edit service" and increase the RAM commitment.  Restarting the service will pull the new value and you should be good to go!

    ------------------------------
    Michael J. Rogers
    Senior Instructor - Zenoss
    Austin TX
    ------------------------------



  • 4.  RE: Zenoss 6.3.2 - Unable to load the visualization library

    Posted 07-09-2020 01:53 AM
    Hi Michael,

    thanks, that is also what I did, please find below the error message I got during service-start:

    "Error occurred during initialization of VM
    Initial heap size set to a larger value than the maximum heap size"

    Thanks

    ------------------------------
    Gerald Müller
    ------------------------------



  • 5.  RE: Zenoss 6.3.2 - Unable to load the visualization library

    Posted 30 days ago

    Hi Michael,

    wanted to let you know I gave it another try and set the parameter back to environment=(JVM_ARGS="-Xmx{{bytesToMB .RAMCommitment}}m")

    This time CentralQuery service started without issues, I tried with different values for RAM commitment but the error message "Initial heap size set to a larger value than the maximum heap size" is not reproduceable anymore. This is a very interesting behaviour, do you know if the parameters used for startup are documented anywhere in the logs?

    Thanks again,
    Gerald



    ------------------------------
    Gerald Müller
    ------------------------------