InstallationGetting Started

Expand all | Collapse all

Python and Zenoss 6.3.2

  • 1.  Python and Zenoss 6.3.2

    Posted 12-30-2019 06:21 PM
    What version of python is packaged with Zenoss 6.3.2? I know that 6.2.1 has python 2.7.5. The release notes don't have any information about python version.

    I'm asking because we upgraded python to 2.7.10 on our Zenoss 6.2.1 install, and it broke Zenoss. Specifically rabbitmq and solr.

    Thanks in advance,
    Larry

    ------------------------------
    Larry
    Sr. Systems Engineer
    IPC Global
    Alpharetta GA
    470-407-9100 ext 136
    ------------------------------


  • 2.  RE: Python and Zenoss 6.3.2

    Posted 12-31-2019 03:28 PM
    Hi Larry

    Zenoss Core 6.3.2 has Python 2.7.5.


    ------------------------------
    Arthur
    ------------------------------



  • 3.  RE: Python and Zenoss 6.3.2

    Posted 12-31-2019 04:37 PM
    Hi Arthur,
        Thanks for your response. Do you know when Zenoss will be moving to Python 3? Support for Python 2.7 ends in 2020:

    https://pythonclock.org/
    https://www.python.org/dev/peps/pep-0373/


    ------------------------------
    Larry
    Sr. Systems Engineer
    IPC Global
    Alpharetta GA
    470-407-9100 ext 136
    ------------------------------



  • 4.  RE: Python and Zenoss 6.3.2

    Posted 01-04-2020 10:36 AM
    Hi Larry

    No idea, I haven't heard anything about this.

    I think latest when RedHat 7.0 is EOL
    https://endoflife.software/operating-systems/linux/red-hat-enterprise-linux-rhel

    Regards

    ------------------------------
    Arthur
    ------------------------------



  • 5.  RE: Python and Zenoss 6.3.2

    Posted 01-13-2020 10:34 PM
    Edited by Larry 01-13-2020 10:35 PM
    Hi Arthur.
       Thanks for your response.

    Best regards,

    ------------------------------
    Larry
    ------------------------------