Configuration & Administration

Expand all | Collapse all

no such image when backing up zenoss 6

  • 1.  no such image when backing up zenoss 6

    Posted 15 days ago
    Edited by David Whiteside 15 days ago
    Any idea why I can't get backups to work on a newly installed ZenOSS 6 core system?

    [root@zenoss-server-iam]# serviced backup /opt/serviced/var/backups
    no such image

    [root@zenoss-server-iam]# journalctl --since "2019-06-04 14:29:00" |grep image
    Jun 04 14:29:47 HOSTNAME serviced[20274]: time="2019-06-04T20:29:47Z" level=info msg="Unable to get history for image zenoss/hbase:24.0.8" error="no such image" location="docker.go:110" logger=dfs.docker
    Jun 04 14:29:47 HOSTNAME serviced[20274]: time="2019-06-04T20:29:47Z" level=info msg="Could not get size for images." error="no such image" location="dfs.go:206" logger=facade

    ------------------------------
    David Whiteside
    HPC System Administrator
    NREL
    ------------------------------


  • 2.  RE: no such image when backing up zenoss 6

    Posted 15 days ago
    I had to re-tag every entry within journalct and it fixed it.  It took a few iterations (each time I fixed one another would appear in the log).  Below is an example of how I fixed one specific service.

    [root@zenoss-server-iam]# docker ps |grep opentsdb
    155f4a65d82e localhost:5000/d5ig9lx0u0hnap5fuuxxq62ei/opentsdb:latest "/serviced/service..." About an hour ago Up About an hour 19l0kql1e7h9e7fa8yujs0hql-0
    fc16da1c2779 zenoss/serviced-isvcs:v61 "/bin/sh -c 'trap ..." About an hour ago Up About an hour 0.0.0.0:4242->4242/tcp, 127.0.0.1:8888->8888/tcp, 127.0.0.1:9090->9090/tcp, 127.0.0.1:58443->58443/tcp, 0.0.0.0:8443->8443/tcp, 127.0.0.1:58888->58888/tcp serviced-isvcs_opentsdb

    [root@zenoss-server-iam]# docker tag localhost:5000/d5ig9lx0u0hnap5fuuxxq62ei/opentsdb:latest zenoss/opentsdb:24.0.8

    ------------------------------
    David Whiteside
    HPC System Administrator
    NREL
    ------------------------------



  • 3.  RE: no such image when backing up zenoss 6

    Posted 12 days ago
    Few questions for you.

    What version of Zenoss/Control Center?
    Did you install using the appliance or install files?
    Did you start the Zenoss application at all before running the backup?

    ------------------------------
    jstanley
    ------------------------------