Configuration & Administration

Expand all | Collapse all

CentralQuery not working (answering)

  • 1.  CentralQuery not working (answering)

    Posted 10-20-2017 02:05 AM
    Hi
    Central query service is in red Health state (answering 0)
    The container log looks like tthis:

    I1020 06:54:32.716888 00001 controller.go:733] Starting service process for service 1ksh9sim1ohe7ikt9f1ojbd1y
    I1020 06:54:32.716938 00001 instance.go:87] about to execute: /bin/sh , [-c exec su - zenoss -c "cd /opt/zenoss && /bin/supervisord -n -c etc/central-query/supervisord.conf"][2]
    2017-10-20 06:54:33,399 INFO Included extra file "/opt/zenoss/etc/central-query/central-query_supervisor.conf" during parsing
    2017-10-20 06:54:33,448 INFO RPC interface 'supervisor' initialized
    2017-10-20 06:54:33,448 CRIT Server 'unix_http_server' running without any HTTP authentication checking
    2017-10-20 06:54:33,449 INFO supervisord started with pid 52
    2017-10-20 06:54:34,451 INFO spawned: 'central-query' with pid 55
    2017-10-20 06:54:34,526 INFO exited: central-query (exit status 1; not expected)
    2017-10-20 06:54:35,529 INFO spawned: 'central-query' with pid 57
    2017-10-20 06:54:35,551 INFO exited: central-query (exit status 1; not expected)
    2017-10-20 06:54:37,555 INFO spawned: 'central-query' with pid 59
    2017-10-20 06:54:37,572 INFO exited: central-query (exit status 1; not expected)
    2017-10-20 06:54:40,577 INFO spawned: 'central-query' with pid 63
    2017-10-20 06:54:40,594 INFO exited: central-query (exit status 1; not expected)
    2017-10-20 06:54:41,594 INFO gave up: central-query entered FATAL state, too many start retries too quickly

    Insance log error:

    October 20th 2017, 08:14:26.883 0 Error occurred during initialization of VM
    October 20th 2017, 08:14:26.883 0 Initial heap size set to a larger value than the maximum heap size

    Anyone can help with this?

    ------------------------------
    thx 4 all
    rop
    ------------------------------


  • 2.  RE: CentralQuery not working (answering)

    Posted 10-25-2017 07:29 AM
    Ok
    Found the solution so if You have similar problems try this:
    From the Control Center web UI You have to choose CentralQuery, (Application/Zenoss.core than expand Services/Metrics, than click CentralQuery)
    On the CentralQuery service page
        edit configuration file: /opt/zenoss/etc/central-query/central-query_supervisor.conf
          replace (delete or comment out) entry: environment=JVM_ARGS="-Xmx{{bytesToMB .RAMCommitment}}m"
          with environment=JVM_ARGS="-Xmx4096m"

    I don't know if it's good idea, but it's work

    ------------------------------
    rop rop
    gov
    ------------------------------