Reporting, Analysis and Analytics

1.  Zope error when test modeling in Zenoss 5

Posted 17 days ago
Hi.

I'm trying to know how to solve a problem that actually the only solution is restart Zope service.

Then I try to launch a test from a Monitoring Template in a device (ie: cpu info), it works great the first time, but in a second time it gives me an exception:

Preparing Command...
Executing command /usr/bin/env [args omitted] against 192.168.0.190
exception while executing command
type: <class 'twisted.internet.error.ReactorNotRestartable'> value:
DONE in 0 seconds

I've tried to increase the Zope instances and the only thing I get is more working times, but start failing again.

Does anyone know what's the problem?

Thanks

------------------------------
Eirisdg
------------------------------


2.  RE: Zope error when test modeling in Zenoss 5

Posted 11 days ago
Anyone more with this problem?

------------------------------
Eirisdg
------------------------------



3.  RE: Zope error when test modeling in Zenoss 5

Posted 11 days ago
This sounds like a bug.  What exact version of Zenoss are you using?  What browser?  If firefox then try Chrome and vice versa.  Try refreshing your browser before the second attempt.  You absolutely shouldn't need to restart Zope!

Cheers,
Jane

------------------------------
Jane Curry
Skills 1st United Kingdom
jane.curry@skills-1st.co.uk
------------------------------



4.  RE: Zope error when test modeling in Zenoss 5

Posted 11 days ago
Tried in Chrome, Firefox and Edge, same error:
Preparing Command...
Executing command /usr/bin/env [args omitted] against 192.168.0.190
exception while executing command
type: <class 'twisted.internet.error.ReactorNotRestartable'> value:
DONE in 0 seconds
The only way to recover the tests is restarting Zope.

I've tried too refreshing navigator and closing and reopening session, but same problemm.
In logs I can't se anything :S

------------------------------
Eirisdg
------------------------------



5.  RE: Zope error when test modeling in Zenoss 5

Posted 11 days ago
What version of Zenoss?
Cheers,
Jane

------------------------------
Jane Curry
Skills 1st United Kingdom
jane.curry@skills-1st.co.uk
------------------------------



6.  RE: Zope error when test modeling in Zenoss 5

Posted 11 days ago
Zenoss Core 5.2.4

------------------------------
Eirisdg
------------------------------



7.  RE: Zope error when test modeling in Zenoss 5

Posted 9 days ago
Any idea?

------------------------------
Eirisdg
------------------------------



'