Configuration & Administration

Outdated root certificate store - Lets Encrypt no longer working

  • 1.  Outdated root certificate store - Lets Encrypt no longer working

    Posted 7 days ago
    Edited by Michael 7 days ago
    Hello,

    We have zenactiond creating tickets in our OTRS system using the OTRS API. This stopped working on September 30 when Lets Encrypt DST Root CA X3 expired. I ran yum update ca-certificates in the underlying OS to get the new root, but the zenactiond container did not have that. I had to run the same command in the zenactiond container itself, which fixed the issue temporarily. However upon rebooting the server, the change to the zenactiond container was not persistent, as expected, and so the problem came back.

    I know of the procedure in the knowledgebase for installing a permanent tool or script, but that is for the main zope container, and in my case it is zenactiond that has to be updated. Does anybody know how to do this?

    THanks.

    ------------------------------
    Michael Ducharme
    CompanyName
    ------------------------------