Reporting, Analysis and Analytics

Expand all | Collapse all

Zenoss server not showing device inventory :

  • 1.  Zenoss server not showing device inventory :

    Posted 22 days ago
    Hello,

    We have a problem with our Zenoss recently.
    Our version is 4.2.3 (has been running for a long time).

    At the "DashBoard" level, the list of "Device Issues" regularly disappears and an error message appears at the top of the page:Connection refused. Check zeneventserver status on <a href="/zport/About/zenossInfo">Daemons</a>

    We continue to receive email alerts as usual.
    We have already tried to recreate the indexes by deleting the two folders: summary and archive ==> but it didn't change anything.

    Can someone help me?
    Thank you very much !

    Benoit.

    ------------------------------
    Benoit Wattiez
    CHUPMB
    ------------------------------


  • 2.  RE: Zenoss server not showing device inventory :

    Posted 17 days ago
    Hello,

    Can't anyone help me? :(
    Thanks

    Benoit

    ------------------------------
    Benoit Wattiez
    CHUPMB
    ------------------------------



  • 3.  RE: Zenoss server not showing device inventory :

    Posted 16 days ago
    Hmmm .  What does your Event Console look like?  Can you open it?  Is it being updated as you would expect?

    I think you are correct in suspecting a problem with the events database, based on that error message, and you have already taken the first step I would suggest which is to clear the indexes.

    Have you tried looking at zeneventserver.log - that's the daemon that inserts events into the zenoss_zep events database and also drives the process to generate notifications (which it sounds like are still working???).

    How big is your zenoss_zep database?  With Zenoss 4.2.3, there may have been later updates that improved the use of the mysql database.    How long do you keep archived events - and do you need to keep them that long?  If you have a huge zenoss_zep database there certainly used to be forum appends around to help reduce its size and its indexes - but it will probably take a long time; the zenoss-provided utilities for database pruning were very inefficient so much better to work directly with mysql.

    Cheers,
    Jane

    ------------------------------
    Jane Curry
    Skills 1st United Kingdom
    jane.curry@skills-1st.co.uk
    ------------------------------



  • 4.  RE: Zenoss server not showing device inventory :

    Posted 16 days ago
    ​Hello,

    Thank you for your answer.
    The dashboard displays the devices correctly but it disappears from time to time (I get this: see zenoss_issue.PNG).

    Indeed, I have already deleted the indexes but that hasn't changed anything.
    For the "zeneventserver.log", I don't see much of an error (and nothing with index), except this:
    2019-10-30T14:26:27.572[qtp1133736492-3021 - http://localhost:8084/zeneventserver/api/1.0/events/tag_severities] ERROR org.jboss.resteasy.core.SynchronousDispatcher - Failed executing POST /1.0/events/tag_severities
    org.jboss.resteasy.spi.WriterException: org.eclipse.jetty.io.EofException
    I don't know if it's important.
    I added the file zeneventserver.log as an attachment. I don't know if you have time to take a look around?

    - The events are well recorded in the logs.
    - The services are well started (see: zenoss_issue_Deamons.PNG).
    - About the size of the database, I don't know if it's correct (see zenoss_issue_size.PNG).
    - I don't know how long we keep the events. Where can I look at this parameter? (the discs are not full).

    What do you advise me to do to improve the situation?

    Perform a zenoss update?

    best regards,

    Benoit.

    ------------------------------
    Benoit Wattiez
    CHUPMB
    ------------------------------

    Attachment(s)

    txt
    zeneventserver.txt   2.95MB 1 version