Configuration & Administration

1.  PythonClient error- aws.s3bucket in zenoss

Posted 6 days ago
  |   view attached
Hi Everyone,

I am not able to model the linux server as we are getting AWS.S3 bucket error while modelling.

Even though there is no plugin as aws.s3 bucket configured on that server, Still we are getting this error.

While troubleshooting,we removed the device and device class ,re added it and tried modelling but facing same error.

Please find the attached screenshots for your reference.

Kindly help on resolving the same.

------------------------------
Manoj M

------------------------------

Attachment(s)

docx
Errors.docx   251K 1 version


2.  RE: PythonClient error- aws.s3bucket in zenoss

Posted 6 days ago
Looking at your log, the server that you are modeling is called EWEA and it DOES have 2 aws plugins - look 7 lines up from the line you highlighted - it is collecting aws.EC2 and aws.S3buckets.  Also, look 3 lines above your highlighted line and it says "No command plugins for EWEA".

I suspect that you have confusion with your devices and you are actually modelling a different device than the one you think you have.

Do some DNS tests to check IP address / name resolution.

Cheers,
Jane

------------------------------
Jane Curry
Skills 1st United Kingdom
jane.curry@skills-1st.co.uk
------------------------------