Configuration & Administration

1.  Zenoss 4.2.5 & Infrastructure/Devices

Posted 10 days ago
I recently created a new 4.2.5 server on CentOS 6, patched it to 732, and tried to install two different ZenPacks.

Both ZenPacks had the same error about not being able to create a sub-folder under Devices so I look in Infrastructure and, under the Devices tab, there's nothing.  No side bar, no icons for creating devices, just a blank white screen.  If I go to the other tabs (Networks, Processes, etc), there are sidebars, etc. but nothing under Devices.

Before I patched, I had told Zenoss to auto-discover devices just to see what it would find and I was able to look in Devices and see that it had only found one or two so it was working before the patch.

Any suggestions?

------------------------------
Clay
Network Computer Technician
------------------------------


2.  RE: Zenoss 4.2.5 & Infrastructure/Devices

Posted 9 days ago
Weird.
Get the toolbox tools if you dont already have them - https://support.zenoss.com/hc/en-us/articles/203117595-How-To-Install-And-Use-the-zenoss-toolbox    .  They should run quite quickly if it is a new build.

Which ZenPacks did you try to install?

Cheers,
Jane

------------------------------
Jane Curry
Skills 1st United Kingdom
jane.curry@skills-1st.co.uk
------------------------------



3.  RE: Zenoss 4.2.5 & Infrastructure/Devices

Posted 9 days ago
ZenPacks.community.Brocade
ZenPacks.vaibhav.brocadeswitches

I installed the tools with no problems.  I ran all the tools with no errors but I'm guessing it was the zenindextool that brought back my Devices screen.

Just wondering, the zennetworkclean shows one orphaned IP but I only have the one Device, localhost.  Should I leave it alone or give it server IP?

Thanks.

------------------------------
Clayton
Network Computer Technician
------------------------------



4.  RE: Zenoss 4.2.5 & Infrastructure/Devices

Posted 8 days ago
So you DO have your Devices tree back OK??

I always add my Zenoss Server with its DNS name, and hence external IP address, rather than let it run as localhost.

Cheers,
Jane

------------------------------
Jane Curry
Skills 1st United Kingdom
jane.curry@skills-1st.co.uk
------------------------------