Configuration & Administration

Expand all | Collapse all

patch and update

  • 1.  patch and update

    Posted 07-02-2020 04:35 AM
    Hi,
    We have some local heartbeat failures and threshold problems.
    It's a system I inherited from a team that left the company. So I don't have much knowledge yet.
    I already followed some advises that I found here on the forum. But it didn't helped.
    My question is: should I patch or update?
    Thanks.
    max

    ------------------------------
    Max
    A modest network guy
    ------------------------------


  • 2.  RE: patch and update

    Posted 07-06-2020 11:28 AM
    Hi, Max!

    The "Versions" page in the UI doesn't really show you your patch level, just that you're on version 4.2.5.  For the patch level, you'll need to ssh to your zenoss host and perform the following:

    su - zenoss
    zenup status​

    The output should let you know your "Recommended Patch Set" (aka, RPS) level.  The last RPS for version 4.2.5 was SP743.  If you're running a version prior to that, you'll want to patch your system up to that level.

    ZenUp Doc
    Upgrade Doc

    RPS Link

    Naturally, make sure you have a good backup per the docs before proceeding.

    As for the latest versions of Zenoss Core / Community Edition, that would be 6.3.2.  Due to changes in the underlying architecture, there is no upgrade path from 4.2.5.  The typical recommendation would be to:

    * Build out a new instance running 6
    * Batchdump your device list from the old instance
    * Batchload your device list into the new instance
    * Run them in parallel until the new instance is configured
    * Cut over when appropriate.

    If you have any questions about the process, feel free to post them here!

    Have a great day, and good luck!

    ------------------------------
    Michael J. Rogers
    Senior Instructor - Zenoss
    Austin TX
    ------------------------------



  • 3.  RE: patch and update

    Posted 07-07-2020 04:03 AM
    Hi Michael,

    Thank you for your time. I started reading your documentation.
    When I perform zenoss status it returns me "No Products Installed".
    Then I tried a "dry run" of the patch and there also, it returns an error.

    Any idea what could be the cause?

    Thanks and have a nice day too!
    Max

    ------------------------------
    Max
    Network Engineer
    ------------------------------



  • 4.  RE: patch and update

    Posted 07-07-2020 05:45 PM

    Max,

    The "no products installed" message indicates that the zenup patching utility has been installed, but has never "registered" the original fileset or applied any patches.  Your next steps should look something like this:

    1. If you haven't already done so, take a backup.
    2. Verify your zenup version: rpm -qa | grep zenup
      1. If you're on 1.1, proceed to step 3.
      2. If you're on 1.0, follow the instructions in the zenup docs to upgrade to 1.1, then proceed to step 3.
    3. Register the pristine:
      1. Check your Redhat/CentOS version with cat /etc/redhat-release.
      2. Download the matching pristine (el5 for RedHat/CentOS 5, or el6 for RedHat/CentOS 6) from here.
      3. Register the pristine with zenup init per the upgrade doc (2.10.3)
    4. Apply the RPS:
      1. Download the RPS from the link previously provided.
      2. Apply the RPS with zenup install per the upgrade doc (2.10.4)

    The "pristine" is essentially a "version 0" copy of every file that the RPS patches.  Zenup will not proceed until a pristine has been registered, so it looks like the previous maintainer never upgraded this instance after installation (or something out of the ordinary broke zenup).

    As to your original question, "should I patch or update," that will come down to the issues you're currently facing.  Can you give some more detail on the heartbeat and threshold problems you're facing?



    ------------------------------
    Michael J. Rogers
    Senior Instructor - Zenoss
    Austin TX
    ------------------------------